Last modified by eMDPlugins - 2 years ago
7 Views
Less than a minute read

What’s required to use your plugins?

In order to use our plugins, you must have a self-hosted WordPress site. Our software is designed and developed for businesses in mind. Although we optimize our software for performance considering limited hardware resources, cheap, shared hosting providers may not offer the performance you need. We recommend you to take a look what WordPress recommends before signing up for a hosting provider.

If you do not have a self-hosted WordPress site, we offer fully managed solutions for your business or organization for a flat monthly or yearly fee. Please contact us by opening a support ticket if you need fully managed solution.

Was this information helpful?